Diagnose Your Car's Problem


Are the dash lights out or extremely dim?


You chose: Sounds Like > A clicking sound
By using the DriverSide Diagnostic Tool, you agree to the Terms of Use.

Or, Ask the DriverSide Mechanics.

Enter a Question:
Details:
Which Car is This Question About?

Recent Questions

Is the car drivable?
I recently had work done on my car to replace cracked tie rods, serpentine belt, front brake replacement and other minor work along with my scheduled oil change. While I was drivin...
Asked by Sandra J February 7, 2016, 9:08 am 1 reply
Why will my Honda only start once in a while
It starts up just fine one day and the next it won't for a couple hours and sometimes it won't start for days. It turns over but it won't ignite can't figure this out
Asked by Mary H February 5, 2016, 6:09 pm 1 reply
Acceleration
The car has started an acceleration problem. I gets off okay but at about 15-20mph, When I press on the gas pedal the pick-up is delayed and then it will kick in and the rpms will ...
Asked by Christopher J February 4, 2016, 2:34 pm 1 reply
my steering wheel is hard to turn
This happens when I'm parallel parking and going reverse. Also, When I turn left or right I hear a dragging noise. The car is just not driving normal.
Asked by Diana R February 6, 2016, 1:19 pm 3 replies
My car won't start
My car isn't starting. It doesn't click or anything. The lights aren't dim and the battery is holding a charge. I even took the starter out and had it tested, and they said it was ...
Asked by Joel R February 4, 2016, 4:13 pm 1 reply
Engine Misfire P0300 and gas smell
The engine generated multiple misfire code p0300. The car had previously genereated p0302 and p0303 I have replaced the spark plugs on all cylindars and the ignition coils on cy...
Asked by Ted N February 4, 2016, 11:53 am 1 reply
it wont start think brain for computer
changed the fuel pump, but someone tried to install a stero system then the van just died in the middle of the highway and now wont even crank over.....
Asked by Lisa C February 3, 2016, 9:11 am 1 reply
No sound in speakers
I replaced my old head unit with a new pioneer DEH-150MP. Connected all the wires correctly and still no sound.
Asked by Zack W February 2, 2016, 7:03 am 1 reply
1 2 3 4 5