Need Help?

1994 Jeep Grand Cherokee Laredo 4dr

1994 Jeep Grand Cherokee
Do you own this car?
Estimated Mileage
 Miles
Enter current mileage for most
accurate info about this vehicle


Track Your Service Records
Get Recall Alerts
Get Updated Value Estimates on Your Car.

back to question list

Ask the Community

Ask Our Auto Mechanics


November 20, 2012, 6:14 pm

Matt I
 

Question: Car bogs down and won't go forward after 20 minutes of driving or 5-7 miles

I have a 1997 Jeep Grand Cherokee Laredo 4.0L.

I'm having a problem with it suddenly not wanting to go forward while driving it, after 20-30 minutes or around 4-7 miles of driving. It stays

running/idling, but when you press the gas, it sputters and starts to die until you let up on the gas pedal. It will only move forward at about 1 or 2

miles per hour(on flat ground), or won't move forward at all.

I can get it to start working normal(it feels like it's running at 95% normal), if I shut it off and let it sit for 5 thru 10 minutes. Then I start it

up again, and it will usually work again(until it heats back up?). While this goes on, the oil pressure is normal, as is the engine/radiator heat level.

All cylinders sound like they are firing right, and it doesn't put out any smoke.
My injectors aren't leaking either.
I do hear a hissing sound coming from the brake booster areas for around 30 seconds when the problem starts up again, but it disappears after I stop

and restart the engine.

I live in an area around 4000 ft above sea level in a Costa Rica mountain area, and the temperature is always between 60F-78F. this area is where I am

experiencing this problem with my Jeep.The nationwide gasoline suppliers do sometimes have batches of dirty gas. Some folks get problems with their fuel

systems because of this.

I was told my fuel filter might be dirty, or the fuel pump was getting ready to give out, but the fuel pump was replaced 4 years ago at the Jeep dealer,

and I only have put around 25,000 miles on it. Any fuel filter or fuel pump will have to be ordered from the US.
I'm thinking it might be something electrical or a problem with the brake booster. I do sometimes get soft brake pressure off and on.
Any ideas?


December 2, 2012, 9:35 am

Richard W
Expert Mechanic

It will be the coil or fuel pump. When this happens get out and check your spark at the spark plug. It need to have good blue spark that can jump about a .25". If you have good spark you will need to check the fuel pump. Or replace it.


0/0 users found this helpful.

Ask our panel of certified auto mechanics a question. We pay for their advice so you don't have to



My Auto Score

See the free AutoCheck score

Meet The Experts
Kim Perrin
Kim Perrin is our resident mechanic here at DriverSide. Kim worked as…
Tyler Orr
Tyler Orr is an expert in German and Japanese cars and has been a mechanic …
Elizabeth Kriesten
Elizabeth Kriesten worked as an automotive technician for several years at Dodge…
Tips on Servicing

Car Brakes: How Do You Know When to Change Them?

By Zach Bowman For those who suffer a daily commute through heavy traffic, your vehicle's braking system can bring thousands of pounds of metal, plastic and empty Starbucks cups to a stop hundreds of times before you get to work. It goes without saying that these pieces wear out, but they do so slowly, meaning you may not notice they need attention until ...

Read more…